ACPI issues (maybe)

Joe Talbott josepht at
Fri Mar 2 23:06:18 PST 2007

On Sat, Mar 03, 2007 at 11:54:46AM +0900, YONETANI Tomokazu wrote:
> Hi.
> Please post any bug reports to bugs@, whether it's ACPI-related or
> not.
> On Fri, Mar 02, 2007 at 08:18:05PM -0500, Joe Talbott wrote:
> > I am experiencing some weird behavior with my Toshiba Satellite
> > M115-S3094 Laptop.  I cannot power off the laptop with shutdown or
> > reboot.  Both go through the steps of shutting down the machine but it
> > never powers off.  I've tried setting hw.acpi.disable_on_poweroff to 1
> > to no avail.  I have to press the power button for 5 or so seconds for
> > it to power off.  So I've been using 'shutdown -h ...' which lets me
> > tap the power button to power off the laptop but this often leaves the
> > speakers beeping throughout the shutdown process.
> Is this bug new in 1.8?  Do you experience this problem when you
> run a UP kernel?

This was happening before 1.8 and also happens with a UP kernel.

> > When doing a 'shutdown -p ...' I do see a message like "Powering off
> > via ACPI" or some similar text flash on the screen before the LCD is
> > blanked, but it isn't completely powered off.
> > 
> > So I tried adding "options ACPI_DEBUG" to my kernel config and rebuilt
> > my kernel.  This left me with a clock that ran at about 1 minute per 1
> > second of real time.
> > Oddly none of the sysctl nodes for hw.acpi were
> > available with this kernel option added.  I don't know if this is due
> > to acpi being loaded as a module or what.
> Sounds like ACPI driver failed to load.  Do you have this problem
> when you boot with ACPI disabled (debug.acpi.disabled="acpi" in the
> boot loader)?

No this only happened with 'options ACPI_DEBUG' in my kernel config


More information about the Bugs mailing list