ACPI issues (maybe)

YONETANI Tomokazu qhwt+dfly at
Sun Mar 4 08:31:25 PST 2007

On Sat, Mar 03, 2007 at 01:41:01AM -0500, Joe Talbott wrote:
> On Sat, Mar 03, 2007 at 11:54:46AM +0900, YONETANI Tomokazu wrote:
> > On Fri, Mar 02, 2007 at 08:18:05PM -0500, Joe Talbott wrote:
> > > I am experiencing some weird behavior with my Toshiba Satellite
> > > M115-S3094 Laptop.  I cannot power off the laptop with shutdown or
> > > reboot.  Both go through the steps of shutting down the machine but it
> > > never powers off.  I've tried setting hw.acpi.disable_on_poweroff to 1
> > > to no avail.  I have to press the power button for 5 or so seconds for
> > > it to power off.  So I've been using 'shutdown -h ...' which lets me
> > > tap the power button to power off the laptop but this often leaves the
> > > speakers beeping throughout the shutdown process.
> > 
> > Is this bug new in 1.8?  Do you experience this problem when you
> > run a UP kernel?
> This was happening before 1.8 and also happens with a UP kernel.

I feel relieved to hear that somehow ;)  I saw a similar problem on
some of PCs around, but disable_on_poweroff always worked.  Does updating
BIOS fix it?

[`options ACPI_DEBUG' skews the clock]
> > > So I tried adding "options ACPI_DEBUG" to my kernel config and rebuilt
> > > my kernel.  This left me with a clock that ran at about 1 minute per 1
> > > second of real time.

> > > Oddly none of the sysctl nodes for hw.acpi were
> > > available with this kernel option added.  I don't know if this is due
> > > to acpi being loaded as a module or what.

I recommend against compiling acpi driver in the kernel.

> > Sounds like ACPI driver failed to load.  Do you have this problem
> > when you boot with ACPI disabled (debug.acpi.disabled="acpi" in the
> > boot loader)?
> No this only happened with 'options ACPI_DEBUG' in my kernel config
> file.

I believe I know it.  In short, don't use that option, and build acpi
driver with an environment variable ACPI_DEBUG set to yes:
  cd /sys/dev/acpica5
  export ACPI_DEBUG=yes
  export CFLAGS='-O -pipe -DSMP=1'	(only for SMP kernel)
  make obj && make depend && make && make install

The problem is that you used an option which only applies to acpi driver
compiled in the kernel, but if you build the kernel by buildkernel or
nativekernel, that option gets propagated to module build without adding
necessary files.  When you reboot your laptop, acpi driver fails to
load because of missing symbols which are supposed to be defined in those
missing files.  If this is the case, /var/run/dmesg.boot should contain
the clue.


More information about the Bugs mailing list