zsleep() and serializer msgport backend

Matthew Dillon dillon at apollo.backplane.com
Tue Mar 4 13:02:05 PST 2008

:>     How about 'serlz' ?
:So, your point is that a short prefix is appropriate for *sleep(), but
:lwkt_serialize_{enter,exit}() and friends make sense? :)
:Maybe sleep with serializer is (will be) used so often zsleep() makes sense,
:or maybe a one letter prefix is better for historical reasons. But on the
:off chance I need to refer to such a function in a face to face conversation,
:I'd prefer it to have a pronouncable name. If it's just a tiny bit consistent
:with the rest of the serializer api, so much the better.

    I never liked the long names for the serializer calls, but I couldn't
    think of a better name.  

    In anycase, you are absolutely correct.  If the serializer API uses
    'serializer' then the sleep API ought to as well.

					Matthew Dillon 
					<dillon at backplane.com>

More information about the Submit mailing list