zsleep() and serializer msgport backend

Aggelos Economopoulos aoiko at cc.ece.ntua.gr
Tue Mar 4 12:54:18 PST 2008

On Tuesday 04 March 2008, Matthew Dillon wrote:
> :
> :Sepherosa Ziehau wrote:
> :> The above patch create:
> :> 1) zsleep(), similar to msleep(), expect serializer is involved
> :
> :I thought we wanted to move to more expressive names, like
> :serialize_sleep() [as proposed by aggelos]?

Actually, it was Matt (quoting from

   "If we're gonna start throwing around different types of sleeps maybe
    we should make the names more verbose. spin_sleep(), lockmgr_sleep(),
    etc.  We don't use them so often that they'll clutter up the code and
    the longer names will make the code more readable."

>     Patch looks great.  I don't mind 'slize' (though it kinda sounds like
>     sleeze, heheheh).  serialized_ is a rather large prefix, lets try to
>     find something shorter.  'z' works in a crunch but it would be nice
>     if we could find a prefix that was in the 3-5 character range. 
>     How about 'serlz' ?

So, your point is that a short prefix is appropriate for *sleep(), but
lwkt_serialize_{enter,exit}() and friends make sense? :)

Maybe sleep with serializer is (will be) used so often zsleep() makes sense,
or maybe a one letter prefix is better for historical reasons. But on the
off chance I need to refer to such a function in a face to face conversation,
I'd prefer it to have a pronouncable name. If it's just a tiny bit consistent
with the rest of the serializer api, so much the better.


More information about the Submit mailing list