rc.d standardization patch

Sascha Wildner saw at online.de
Fri Sep 29 09:37:47 PDT 2006

Victor Balada Diaz wrote:
I've created a patch[1] inspired by yours that allows to use
foo_enable="YES|NO" and foo="YES|NO" with pkgsrc and base apps.
It's much smaller, don't require documentation changes and gives
us the choice of working the way we want without imposing anything
to the user.
This is a bit hackish, because the place it should be fixed is on
pkgsrc, but i doubt this is doable as of now.
I like your patch because (even though it's kind of a hack) it gives 
everyone the freedom to use the style he prefers with a minimum of effort.

Personally, I prefer "foo_enable" to just "foo". I tend to think we 
shouldn't deprecate it just because pkgsrc doesn't properly adapt to the 
rc semantics of all its target platforms. :)

I think this should be committed.



More information about the Submit mailing list