Signal 11 and the amd64 port

Matthew Dillon dillon at
Mon Sep 21 11:02:21 PDT 2009

:I just installed a new DragonFly/amd64 system on a blank disk. Most of the
:basic applications (base system, non-graphic packages) work fine.
:While building applications from pkgsrc, I noticed many crashes of make(1)
:with signal 11s. Nevertheless, I was able to install most of the programs I

    You mean bmake ?  pkgsrc uses bmake.

:Things took a turn for the worse when I tried to run X11. None of the window
:managers I tested could run. They all crashed with signal 11s.
:The only application I was able to run under X is xterm. All others I could
:test crashed immediately after launch.
:I don't believe the new amd64 port should be so unstable. My test machine is
:a Core 2 Duo system and runs DragonFly/i386 perfectly fine.
:What can I do to find out what's wrong with X11 applications ?
:Francois Tigeot

    I haven't tried X stuff yet but we are not seeing any signal 11's on
    our 64-bit package source building box, other then from 'conftest'
    which is supposed to crash.

    I'll update to the latest master just to make sure some recent commit
    did not create an issue.

    I'm not sure what the issue could be if 32-bit works fine on the box.
    Do you have the system frequency tuned up or is it running stock?

					Matthew Dillon 
					<dillon at>

More information about the Kernel mailing list