SMP users needed to test patch

YONETANI Tomokazu qhwt+dfly at
Wed Nov 4 16:56:16 PST 2009

On Thu, Nov 05, 2009 at 01:55:33AM +0200, Stathis Kamperis wrote:
> > Are we suppose to perform the tests (make -k run and the last two lines)
> > as root or a non-root user? 〓I just tried that on vkernel, but if I run
> As non-root.
> (All the tests in the repository assume non-root runtime context. I
> should have mentioned that, sorry.)
> > them as root, t_mq_open, t_mq_open_umask dump core, and any subsequent
> > runs dump core too, no matter run as root or not. 〓The version of
> That's "expected".
> When the tests failed for the first time (due to being ran as root) ,
> the message queues remained in the system. So every subsequent attempt
> to run the tests again, failed because those queues were already
> present (opened) in the system. I will fix it by installing a signal
> handler that cleans up the mess upon SIGABRT. (Actually, IIRC, some
> tests may already have such a thing.)

OK, thanks for the explanation.

> Most important is that vkernel didn't crash or hang :)
> I assume that you didn't pass -n1 to the vkernel, right ?

I used -n3 and -n16 but vkernel didn't crash or hang in either cases,
so I tried it on the real kernel too, but so far all tests ran fine and
I haven't managed to crash :).
Oh, t_mq_send failed at line 56 after raising kern.mqueue.mq_prio_max to 200,
but if I put it back to default (32), the test passes. Is it expected too?


More information about the Kernel mailing list