wireless ethernet

Hiten Pandya hmp at backplane.com
Tue Aug 30 19:02:42 PDT 2005

Isn't the 'channel' supposed to have a decent value instead of -1 ?  Try 
changing that, it might help.  Check what channel your base station is 
broadcasting on first.


Jon Hamilton wrote:
I've been trying to get my laptop (HP Pavillion ze4500) working with my wireless ethernet,
and am sure I'm overlooking something obvious.  I have a number of cards available, all of
which seem to behave in a similar fashion: ifconfig seems to see them fine, reports their
MAC address correctly, etc; I can't get any of them to associate with my base station under
DragonFly.  All of the cards do work fine with the same base station under various other 
operating systems on various machines.

The lowest common denominator among the cards is a DWL-650 which works with the wi driver
(and which I've used on the same network with FreeBSD before, albeit on a different laptop).
The base station is fine; it works with a number of other machines on the network.  I 
attempted to reset the base station (a Linksys WAP54G) to its factory default configuration,
and left MAC filtering and WEP off.  Still no luck.  I can ifconfig the card up:

# ifconfig wi0 ssid linksys up

and everything appears fine, but the card won't associate.  The access point log
does not show any activity, either.
I've attached below a dmesg from ``boot -v'', pciconf -lv, and ifconfig output.  If anyone
can point me in a useful direction, I'd appreciate it.  I've tried to do what homework I can
but am spinning my wheels; probably it's something staring me in the face.
Thanks for any suggestions.

	ether 00:05:5d:f2:c1:50
	media: IEEE 802.11 Wireless Ethernet autoselect (DS/2Mbps)
	status: no carrier
	ssid linksys 1:linksys
	stationname "DragonFly WaveLAN/IEEE node"
	channel -1 authmode OPEN powersavemode OFF powersavesleep 100
	rtsthreshold 2312 protmode CTS
	wepmode OFF weptxkey 1

More information about the Kernel mailing list