HEAD broken at the moment?

Bill Hacker wbh at conducive.org
Fri Apr 8 22:20:27 PDT 2005

Chris Pressey wrote:

On Thu, 07 Apr 2005 12:44:05 -0400
Scott Ullrich <geekgod at xxxxxxxxxxx> wrote:

YONETANI Tomokazu wrote:

But `make -sj5 buildworld' on a source tree without -P worked for
me. I think the real issue is here:

make buildworld MAKEOBJDIRPREFIX=/ > & ~/build_log

You're trying to put generated files inside your source tree. It may
work for a build in a sub directory, but probably not for
buildworld. And I wonder if specifying MAKEOBJDIRPREFIX or DESTDIR
with anything other than via environment variable works well with
bulidworld, because variable assignment on command line has higher
precedence than via environment variable, and it gets passed down
recursively via MAKEFLAGS.
The puzzling thing is that this worked great when I did the 
openssh-3.9p1 import.   Is this something to do with the SUS changes? 
I  remember on 5.X the create jail script changed and it sounds
somewhat  similar where you have to pass the ENV variables down the

This worked for me:

  env MAKEOBJDIRPREFIX=/home/cpressey/root/usr/obj make buildworld

Haven't figured out how to make a fake, as-non-root-user installworld
happen yet, though.  This mess:
  env MAKEOBJDIRPREFIX=/home/cpressey/root/usr/obj make \
      SHAREOWN=cpressey SHAREGRP=2011 \
      INSTALL="sh `pwd`/tools/install.sh" \
      DESTDIR=/home/cpressey/root installworld
gets me as far as I have gotten so far, but it chokes on trying to use
"install-info" from within lib/libcom_err/doc, which (presumably) fails
while trying to chgrp and chown what it's installing, as a normal user
AFAIK, all that needs is a jail, where you are seen to BE 'root'.

Anything less - even a 'wheel' user - will probably NOT work.
It isn't supposed to work! (Nor do I understand why anyone should want 
it to).


More information about the Kernel mailing list