HEAD broken at the moment?

Chris Pressey cpressey at catseye.mine.nu
Fri Apr 8 20:29:09 PDT 2005

On Thu, 07 Apr 2005 12:44:05 -0400
Scott Ullrich <geekgod at xxxxxxxxxxx> wrote:

> YONETANI Tomokazu wrote:
> > But `make -sj5 buildworld' on a source tree without -P worked for
> > me. I think the real issue is here:
> > 
> >>make buildworld MAKEOBJDIRPREFIX=/ > & ~/build_log
> >  
> > You're trying to put generated files inside your source tree. It may
> > work for a build in a sub directory, but probably not for
> > buildworld. And I wonder if specifying MAKEOBJDIRPREFIX or DESTDIR
> > with anything other than via environment variable works well with
> > bulidworld, because variable assignment on command line has higher
> > precedence than via environment variable, and it gets passed down
> > recursively via MAKEFLAGS.
> The puzzling thing is that this worked great when I did the 
> openssh-3.9p1 import.   Is this something to do with the SUS changes? 
> I  remember on 5.X the create jail script changed and it sounds
> somewhat  similar where you have to pass the ENV variables down the
> stack.

This worked for me:

  env MAKEOBJDIRPREFIX=/home/cpressey/root/usr/obj make buildworld

Haven't figured out how to make a fake, as-non-root-user installworld
happen yet, though.  This mess:

  env MAKEOBJDIRPREFIX=/home/cpressey/root/usr/obj make \
      SHAREOWN=cpressey SHAREGRP=2011 \
      INSTALL="sh `pwd`/tools/install.sh" \
      DESTDIR=/home/cpressey/root installworld

gets me as far as I have gotten so far, but it chokes on trying to use
"install-info" from within lib/libcom_err/doc, which (presumably) fails
while trying to chgrp and chown what it's installing, as a normal user


More information about the Kernel mailing list