ed1 mistakenly known as wi0 (Was: Re: Heads up: NEWCARD is coming)

Tomaž Borštnar tomaz.borstnar at over.net
Tue Feb 17 02:30:04 PST 2004

eader.dragonflybsd.org> <20040217100427.GA880 at xxxxxxxxxxxxxxxxx>
In-Reply-To: <20040217100427.GA880 at xxxxxxxxxxxxxxxxx>
Content-Type: text/plain; charset=windows-1252; format=flowed
Content-Transfer-Encoding: 8bit
Lines: 48
Message-ID: <4031ed30$0$184$415eb37d at xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx>
X-Trace: 1077013808 crater_reader.dragonflybsd.org 184
Xref: crater_reader.dragonflybsd.org dragonfly.kernel:3846

Joerg Sonnenberger pravi:

>>it worked first time :)
>>Machine was started as usual - without any pcmcia cards present. I inserted 
>>xl device and got this:
>>Feb 17 08:26:30  /kernel: Product version: 5.0
>>Feb 17 08:26:30  /kernel: Product name: 3Com Corporation | 3CCFEM656B-LAN | 
>>LAN | 1 |
>>Feb 17 08:26:30  /kernel: Manufacturer ID: 02016265
>>Feb 17 08:26:30  /kernel: Functions: Network Adaptor, Multi-Functioned
>>Feb 17 08:26:30  /kernel: CIS reading done
>>Feb 17 08:26:30  /kernel: cardbus0: Resource not specified in CIS: id=18, 
> I'll have a look at this.
Perhaps modem part of the card since it is dual-purpose - analog modem and LAN card.

>>Feb 17 08:26:30  /kernel: cardbus0: <unknown card> (vendor=0x10b7, 
>>dev=0x6563) at 0.1 irq 10
>>Feb 17 08:26:48  /kernel: module_register: module cardbus/xl already exists!
> This was a small failure in my patch. The updated version should fix that.
No problem.

>>Feb 17 08:26:48  /kernel: linker_file_sysinit "if_xl.ko" failed to 
>>register! 17
>>Ifconfig showed the xl device with no media. But simple ifconfig xl0 up 
>>solved the problem :) And it correctly discovered my 100Mbps switch :)
If the card is plugged in while booting it is correctly activated - up and configured for media.

>>Had some problems with dc cards about missing BUS_DMA_ZERO, but intend to 
>>check if something is missing in my sources and test that now as well.
> Have you updated sys/i386 and sys/vm as well? I've added that flag yesterday.
Yes, after updating my sources it compiled without problem.
But upon invocation (inserting the card or being present while booting) it locks my sistem so hard that I can not even get into 
DDB. I have no problem manually jumping into DDB on this machine otherwise. It does not affect stability of machine if dc card is 
not present. Last line before freezing is
dc0: <Intel 21143 10/100BaseTX> port 0x1000-0x107f mem 0x88002000-0x880023ff irq 10 at device 0.0 on cardbus0


More information about the Kernel mailing list