[DragonFlyBSD - Bug #3328] rcenable will not add `_enable` prefix

bugtracker-admin at leaf.dragonflybsd.org bugtracker-admin at leaf.dragonflybsd.org
Sat Jan 7 10:54:51 PST 2023

Issue #3328 has been updated by mneumann.

@daftaupe: Thanks for testing this. Can you also test if "/etc/rc.d/dhcpd restart" works properly? If yes, then all works perfectly fine and I was just confused by the man page or I might have tried to enable another service without _enable suffix and that did not work as rcvar is set differently for that service. I think, allowing dhcpd=YES but not e.g. postgresql=YES would be confusing...

No, there *is* a "dhcpd_enable=NO" in my defaults rc.conf, so please ignore what I was writing. There is no dhcpd_enable in FreeBSD's defaults rc.conf :).

Bug #3328: rcenable will not add `_enable` prefix

* Author: mneumann
* Status: Closed
* Priority: Normal
* Target version: 6.4
* Start date: 2022-09-13
When I run

rcenable dhcpcd

I get the following line added to rc.conf:


While I'd expect it to be:


You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

More information about the Bugs mailing list