vkernel filesystem checks fail

Joe Talbott josepht at cstone.net
Fri May 25 16:33:48 PDT 2007

On Fri, May 25, 2007 at 03:54:09PM -0700, Matthew Dillon wrote:
> :I'm running a HEAD vkernel (from today) on a HEAD machine from May 13,
> :2007 and I get the following error during the filesystem checks.  I
> :assume this is related to the recent disklabel work.  I'm not sure
> :what I should or can do to fix this.  I tried creating a new root
> :image but had the same problem.
> :
> :Can't stat /dev/vkd0a: No such file or directory
> :Can't stat /dev/vkd0a: No such file or directory
> :/dev/vkd0a: CAN'T CHECK FILE SYSTEM.
> :
> :I also tried using the new disklabel
> :in /usr/obj to fix the disklabel for vn0 but got this error:
> :
> :$ .../disklabel -e vn0
> :disklabel: Operation not supported by device
> :
> :Thanks,
> :Joe
>     I'm going to guess that your disk image did not use a MBR or fdisk,
>     but just had a straight disklabel.  In that case try accessing it via:
>     disklabel vn0s0

You are correct that it is a straight disklabel.  However my host
system is from before your disklabel update.  I don't have a vn0s0 in
/dev though I do have a vn0s1 but get this error when using disklabel
on it:

disklabel: ioctl DIOCGDINFO: Inappropriate ioctl for device


More information about the Bugs mailing list