vkernel filesystem checks fail

Matthew Dillon dillon at apollo.backplane.com
Fri May 25 15:55:36 PDT 2007

:I'm running a HEAD vkernel (from today) on a HEAD machine from May 13,
:2007 and I get the following error during the filesystem checks.  I
:assume this is related to the recent disklabel work.  I'm not sure
:what I should or can do to fix this.  I tried creating a new root
:image but had the same problem.
:Can't stat /dev/vkd0a: No such file or directory
:Can't stat /dev/vkd0a: No such file or directory
:I also tried using the new disklabel
:in /usr/obj to fix the disklabel for vn0 but got this error:
:$ .../disklabel -e vn0
:disklabel: Operation not supported by device

    I'm going to guess that your disk image did not use a MBR or fdisk,
    but just had a straight disklabel.  In that case try accessing it via:

    disklabel vn0s0

    Remake your vn0* devices if necessary (cd /dev; ./MAKEDEV vn0).

    Same with vkd.  Mount the root image with vn and remake the devices in
    the root image's /dev.  Inside the vkernel the mount points will probably
    be vkd0s0a, etc.

					Matthew Dillon 
					<dillon at backplane.com>

More information about the Bugs mailing list