GCC3 question.

Scott N lvpoker at cox.net
Tue Jun 15 02:38:46 PDT 2004

In article <40cec08c$0$50171$415eb37d at xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx>, 
adamk at xxxxxxxxxxxx says...
> Adam K Kirchhoff <adamk at xxxxxxxxxxxx> wrote:
> > Adam K Kirchhoff <adamk at xxxxxxxxxxxx> wrote:
> >> Joerg Sonnenberger <joerg at xxxxxxxxxxxxxxxxx> wrote:
> >>> On Mon, Jun 14, 2004 at 10:21:31PM +0000, Adam K Kirchhoff wrote:
> >>>> BTW, is buildworld supposed to work with gcc3.3?  I just tried, but it
> >>>> died with:
> >>>> 
> >>>> cc -fpic -DPIC -O -pipe -mcpu=pentiumpro -DLIBC_RCS -DSYSLIBC_RCS -I/usr/src/lib/libc/include -D__DBINTERFACE_PRIVATE -DINET6 -DPOSIX_MISTAKE -I/usr/src/lib/libc/../libc/locale -DBROKEN_DES -DYP  -c /usr/src/lib/libc/string/wmemset.c -o wmemset.So
> >>>> building shared library libc.so.4
> >>>> /usr/obj/usr/src/ctools_i386_i386/usr/libexec/binutils214/elf/ld: cannot open crtbeginS.o: No such file or directory
> >>> Yes, it is. Please cvsup and try again.
> >> Thanks, but still no luck.  I've cvsup'ed twice, and gave it a whirl,
> >> but it's dying at the exact same place.
> > I'm gonna wipe my copy of the tree and pull everything again in case
> > there's something funky going on here.
> Well, it's definitely broken.  Still dying in the same place.  I'll try
> with gcc2 later to see if it's gcc3 specific.
> Adam

I just cvsup'd my DragonFly server yesterday (5/14) and tried to do a 
buildworld and it crashed too. And I REMEMBER something about it 
stopping in binutils214 as well. It was late at work already so I just 
passed it off. Deleted the src tree as well and figured I would try to 
re-cvsup it and try again when I come into work Tuesday.

More information about the Bugs mailing list