GCC3 question.

Adam K Kirchhoff adamk at voicenet.com
Tue Jun 15 02:25:33 PDT 2004

Adam K Kirchhoff <adamk at xxxxxxxxxxxx> wrote:
> Adam K Kirchhoff <adamk at xxxxxxxxxxxx> wrote:
>> Joerg Sonnenberger <joerg at xxxxxxxxxxxxxxxxx> wrote:
>>> On Mon, Jun 14, 2004 at 10:21:31PM +0000, Adam K Kirchhoff wrote:
>>>> BTW, is buildworld supposed to work with gcc3.3?  I just tried, but it
>>>> died with:
>>>> cc -fpic -DPIC -O -pipe -mcpu=pentiumpro -DLIBC_RCS -DSYSLIBC_RCS -I/usr/src/lib/libc/include -D__DBINTERFACE_PRIVATE -DINET6 -DPOSIX_MISTAKE -I/usr/src/lib/libc/../libc/locale -DBROKEN_DES -DYP  -c /usr/src/lib/libc/string/wmemset.c -o wmemset.So
>>>> building shared library libc.so.4
>>>> /usr/obj/usr/src/ctools_i386_i386/usr/libexec/binutils214/elf/ld: cannot open crtbeginS.o: No such file or directory

>>> Yes, it is. Please cvsup and try again.

>> Thanks, but still no luck.  I've cvsup'ed twice, and gave it a whirl,
>> but it's dying at the exact same place.

> I'm gonna wipe my copy of the tree and pull everything again in case
> there's something funky going on here.

Well, it's definitely broken.  Still dying in the same place.  I'll try
with gcc2 later to see if it's gcc3 specific.


More information about the Bugs mailing list