iostat patch: Add dillon's systat changes to iostat

Chris Turner c.turner at
Thu Mar 18 16:25:38 PDT 2010

Jan Lentfer wrote:
Matthew Dillon schrieb:
    I am considering removing the tps/r, tps/w from systat -vm 1 and
    just having tps, but keeping MBs/r and MBs/w.  I think people will
    get more out of an aggregate tps stat.  Then for systat -vm 1
    we would have:  (KB/t, tps, MBs/r, MBs/w) (I should rename those to
    MBr/s and MBw/s I guess too).
Just popped in my head - maybe some kind of format-string type of thing
might make sense here .. e.g:
VMSTAT_IOFMT="%k %t %R %W" -> KB/t tps MBs/r, MBs/w

with the default being set to whatever, and some sort of
'convention' r.e. what upper case vs lower case means
to make it intuitive..
no patch in attachments - sorry guys :)


More information about the Submit mailing list