installation in virtualbox

Sdävtaker sdavtaker at
Mon Apr 26 19:48:21 PDT 2010

Follow up, Installed 2.6, 2.7, with and without bootblocks, packaged and unpackeged, in the 2 different versions, also used 3 different flavors of 2.7, last 3 days builts, with different memory amounts, 128, 256, 386.

All got the same problem.Steps to reproduce:Create a new VM, with this config: OS_other-unknown,  netrwork card pci-fast II.Mount the iso image downloaded from DragonFlyBSD site, 2.6 or 2.7.Start the VM.

It will try to load kernel, and panic somewhere in the middle.When loading the kernel it will  panic and prompt the debugger.write reset and enter.It will restart and boot normally, with no problems at all.

Select install with all the suggested options.when installer prompts to remove the CD. unmount and reboot.It will work fine, if you reboot, it will work fine, if you turn off with shutdown -p now and reboot it will work fine, if you turnoff the machine from VM options, next time you start the same problem arises and you will get the debugger prompt, after reset it will start working ok again.

The way i tested it worked ok, was rebuild full world, full kernel, install kernel, reboot, download some applications, use them, vim, so, it could stay turned on for 2 days, no problems.Only issue reported by dmesg in 2 days was the rebalance failure because of low memory.

Should i report the issue to virtualbox?Do you think the report is complete enough or should I expand it more?Thanks for any suggestions DamianOn Thu, Apr 22, 2010 at 17:13, Sdävtaker <sdavtaker at> wrote:

follow up:Reproduced the installation in a Ubuntu today, 3.0.8 r53138.When trying to install it paniced at first, then i ran reset from the db> and tried again, installed successfull, built 2.7.2 kernel (didnt install it yet, still 2.6.2), everything working fine after that, kept it building and installing stuff whole day, no issues at all.

Going to install 2.7.2 now to see if everything is ok with it, the mac one was ok with 2.7.2 until now.DamianOn Thu, Apr 22, 2010 at 14:01, Justin C. Sherrill <justin at> wrote:

On Thu, April 22, 2010 1:05 pm, Sdävtaker wrote:
> Hi everyone,
> I see that documentation in dfbsd site says it is not able to install in
> vbox, but i got it working, even with network.
> using dfbsd 2.6.2 in vbox 3.1.6 r59359.
> The only special thing i did was change the device used for network
> to PCnet-PCI II (NAT).
> It was detected and worked perfect, already downloaded full src from git
> and rebuilding kernel on it with no problems at all.

Update the site!  Virtualbox problem reports have been sporadic - some
versions work on some platforms, while other versions do not.  It seems to
be clearing up, so perhaps a note mentioning trouble in the past is best.



More information about the Kernel mailing list