Signal 11 and the amd64 port

Francois Tigeot ftigeot at
Mon Sep 21 13:24:19 PDT 2009

On Mon, Sep 21, 2009 at 10:51:40AM -0700, Matthew Dillon wrote:
> :I just installed a new DragonFly/amd64 system on a blank disk. Most of the
> :basic applications (base system, non-graphic packages) work fine.
> :
> :While building applications from pkgsrc, I noticed many crashes of make(1)
> :with signal 11s. Nevertheless, I was able to install most of the programs I
> :wanted.
>     You mean bmake ?  pkgsrc uses bmake.

I didn't really pay attention at the moment.
I definitely saw some gmake processes in the lot.

> :Things took a turn for the worse when I tried to run X11. None of the window
> :managers I tested could run. They all crashed with signal 11s.
> :The only application I was able to run under X is xterm. All others I could
> :test crashed immediately after launch.
>     I haven't tried X stuff yet but we are not seeing any signal 11's on
>     our 64-bit package source building box, other then from 'conftest'
>     which is supposed to crash.
>     I'll update to the latest master just to make sure some recent commit
>     did not create an issue.

I have updated the system. The only changes I got where in hammer and
Applications still crash as before.

>     I'm not sure what the issue could be if 32-bit works fine on the box.
>     Do you have the system frequency tuned up or is it running stock?

It is running stock, with good cooling and a reputable brand power supply.
And since I am really a stability fan, the mainboard features ECC memory.

Francois Tigeot

More information about the Kernel mailing list