Kernel panic during boot in usb_add_task

Bill Hacker wbh at
Tue Nov 20 06:27:31 PST 2007

Michael Neumann wrote:

I tried my brand new HP Compaq laptop 6710b under DragonFly, but during 
the installer CD it "throws" a page fault:

  uhub0: 2 ports ...
  uhub0: <Intel UHCI root hub, ...>
  Fatal trap 12: page fault while in kernel mode
  fault virtual address = 0x0
  fault code            = supervisor write, page not present
  instruction pointer   = 0x8:0xc04a9c5c
  stack pointer         = 0x10:0xc25f8d38
  frame pointer         = 0x10:0xc25f8d48
  code segment          = base 0x0, limit 0xfffff, type 0x1b
                        = DPL 0, pres 1, def32 1, gram 1
  processor eflags      = interrupt enabled, resume, IOPL = 0
  current process       = Idle
  current thread        = pri 46 (CRIT)
  kernel: type 12, code=2
  stopped at       usb_add_task+0x4c:    movl     %edi,0(%eax)
This happens with the latest snapshot version as of yesterday and also 
with the
1.10 release.

FreeBSD 7.0-BETA3 silently hangs during boot, while NetBSD 4.0RC_4 works 
like a charm (it can even dual-boot windows natively)!

Any hints?


For starters, what does NetBSD report as the hardware and can you capture *any* 
scan, dmesg, or other report from FreeBSD 7-BETA3 or DFLY?

And have you tried DFLY and/or FreeBSD with the various boot options selected - 
or can you not get far enough to do so?


More information about the Kernel mailing list