ACPI issues (maybe)

Joe Talbott josepht at
Fri Mar 2 17:53:50 PST 2007

I am experiencing some weird behavior with my Toshiba Satellite
M115-S3094 Laptop.  I cannot power off the laptop with shutdown or
reboot.  Both go through the steps of shutting down the machine but it
never powers off.  I've tried setting hw.acpi.disable_on_poweroff to 1
to no avail.  I have to press the power button for 5 or so seconds for
it to power off.  So I've been using 'shutdown -h ...' which lets me
tap the power button to power off the laptop but this often leaves the
speakers beeping throughout the shutdown process.

When doing a 'shutdown -p ...' I do see a message like "Powering off
via ACPI" or some similar text flash on the screen before the LCD is
blanked, but it isn't completely powered off.

So I tried adding "options ACPI_DEBUG" to my kernel config and rebuilt
my kernel.  This left me with a clock that ran at about 1 minute per 1
second of real time.  Oddly none of the sysctl nodes for hw.acpi were
available with this kernel option added.  I don't know if this is due
to acpi being loaded as a module or what.

My dmesg can be found here:

My uname is:
josepht at neptune$ uname -a
DragonFly neptune.blah.blah 1.9.0-DEVELOPMENT DragonFly
1.9.0-DEVELOPMENT #121: Sat Mar  3 03:19:31 EST 2007
root at  i386

Notice the time is way off.  It's currently Fri Mar 2 20:37 EST 2007.

If there is any more information I can give let me know.


More information about the Kernel mailing list