system freeze on objcache_get

Simon 'corecode' Schubert corecode at
Sun Jul 29 14:21:13 PDT 2007


on the build machine I just had a de-facto system freeze where all processes would get stuck in objcache_get (^T told me).  I couldn't get more information, unfortunately :/  But I could run reboot to get the machine going again, thankfully.

The box was running two and a half days, basically building non-stop.  When I tried to set up another machine I tried duplicating the filesystems with cpdup over ssh and this was REAL slow, until I suspended all build processes.  I don't know, maybe that has something to do with the objcache stuff?  (would hint me towards mbuf or vfs).  Sorry that I don't have more information.

Maybe we should find a way to make objcache_get interruptible (for instance if M_NULLOK is passed?)

Serve - BSD     +++  RENT this banner advert  +++    ASCII Ribbon   /"\
Work - Mac      +++  space for low €€€ NOW!1  +++      Campaign     \ /
Party Enjoy Relax   |      Against  HTML   \
Dude 2c 2 the max   !       Mail + News   / \

More information about the Kernel mailing list