DragonFly and Thinpad X61s

Hasso Tepper hasso at estpak.ee
Sat Dec 8 01:22:56 PST 2007

I got a new toy and of course trying to get it all working with
DragonFly. All went surprisingly good - install with current HEAD,
snd_hda(4) and em(4) are working fine as does X (Intel 965 chipset).

All went well until I tried to boot without power supply. It didn't boot
any more, but just hanged right after detecting SATA controller before
(while?) detecting harddisk. I played with various settings in BIOS (AHCI
vs. Compatibility mode) and here are the results:

HEAD AHCI with AC             - OK
HEAD AHCI without AC          - hangs after detecting SATA controller
HEAD Compatibility with AC    - hangs before detecting SATA controller
HEAD Compatibility without AC - hangs before detecting SATA controller

1.10 AHCI with AC             - OK
1.10 AHCI without AC          - hangs after detecting SATA controller
1.10 Compatibility with AC    - OK
1.10 Compatibility without AC - OK

All other OS'es I tried to boot on it work fine in every situation (with
and without AC) - Linux (Debian), NetBSD (Jibbed LiveCD) and FreeBSD 7.0
beta 4 installer. The last one is particularly interesting, because we
should share the ATA code with FreeBSD 7. I also tried to disable ACPI,
played with various powermanagement settings in the BIOS, but couldn't
make any difference.

There is also too few changes in the ATA to explain regression 1.10 ->
HEAD with compatibility mode, but I'll certainly try to play with
reverting these. I also played with some desktop machines trying to boot
HEAD on them. Results are bad - out of 5 machines only one booted with
AHCI, two I could get booting with legacy IDE mode, two didn't boot at
all. Problems are same - booting just hangs at some point around ATA
controllers detecting. So, there seems to be worryingly a lot of issues
with IDE we need to fix IMHO.

So, any ideas how should I continue? How to debug it? Any help is


More information about the Kernel mailing list