Areca Cards?

Brandon Johns brandon.johns at
Thu Apr 19 17:17:12 PDT 2007

I installed the card and drives the other day in a machine running
1.6.1-REL. I was preparing to upgrade this to the latest preview
tag and see if that made any difference, but thought I would ask
here first what the status of drivers were. dmesg does report an
unknown device and pciconf does list the device, but alas no
other magic. I'm really looking forward to trying this card, because
of all the reviews I've seen.
Dmesg output
pci0: <unknown card> (vendor=0x1022, dev=0x746a) at 7.2 irq 2
pci0: <PCI to Other bridge (vendor=1022 device=746b)> at 7.3
pci0: <unknown card> (vendor=0x1022, dev=0x746d) at 7.5 irq 9
pcib2: <PCI to PCI bridge (vendor=1022 device=7450)> at device 10.0 on pci0
pci2: <PCI bus> on pcib2
pciconf -lv output
none5 at pci4:14:0:        class=0x010400 card=0x112017d3 chip=0x112017d3
rev=0x00 hdr=0x00
   vendor   = 'Areca Technology Corporation'
   device   = 'ARC-1120 8-Port PCI-X to SATA RAID Controller'
   class    = mass storage
   subclass = RAID


On 4/19/07, Bill Hacker <wbh at> wrote:
Brandon Johns wrote:
> Hello all,
> I've recently purchased an Areca ARC-1120 PCI-X raid controller
> and was wondering what the status of drivers were for this
> card.  I've tried the latest preview tag but was unable to find
> anything that remotely appeared to be a driver.  If someone could
> point me in the right direction I'd greatly appreciate it. I did find in
> the mail archive something about the driver being ported, but that
> was all there was. I would love to see just how well this card and
> a few 320gb drives can perform under DFly.
> Thanks in advance,
> Brandon.
It was announced in 2003, has been favorably reviewed, uses an Intel CPU and
Marvel controller chipset:

so... has at least Loonix & FreeBSD drivers.

Have you tried it with DFLY?


More information about the Kernel mailing list