Soekris net4801 and DragonFly BSD

Mischa Peters dfbsd at
Tue Apr 10 14:12:50 PDT 2007

Hi Matt,

ttyd0   "/usr/libexec/getty std.9600"   dialup  off secure

						change from off to on
    From the dmesg output it looks like it booted, but simply never
    started up a getty on the serial port, so that change should do  
That is indeed correct. I have tried a couple of things, but no cigar.

I have tried to change /etc/ttys on the Live CD file system before it  
was NFS mounted, didn't work.
But as far as I can see it's the NFS exported fs.
I have tried changing the read-only export to a read-write export.

Are these things correct, or do I need to setup a server first and  
then setup a NetBoot server, and not use the Live CD NetBoot.

    There are also clearly some problems with calls to /bin/kenv in
    the diskless rc script, probably because kenv was moved to /usr/ 
bin and
    the rc script has the wrong location.
Being able to do this from the Live CD NetBoot would be great!
I have 2 Soekris net4801, 1 net4501 and 2 VIA Machines that I would  
like to rebuild with this. They are now all running OpenBSD.


More information about the Kernel mailing list