pcmcia problems

Matthew Dillon dillon at apollo.backplane.com
Sat Jun 25 14:56:53 PDT 2005

:my laptop refuses to work with any PCMCIA network adapter I've tried so 
:far, that being ed(4), ep(4) and rl(4). ed and rl give me 
:device/watchdog timeouts. ep doesn't give any messages but is extremely 
:slow (1 KB/s). I guess I'm having interrupt problems.
:I've tried running without ACPI, disabling things in the BIOS (which 
:offers only a limited set of choices) and removing stuff from my kernel 
:config, all to no avail.
:Verbose dmesg output (without ACPI and my rl plugged in) is at 
:http://yoyodyne.ath.cx/stuff/dmesg.boot (note the intr 9 livelock).
:P.S. In Knoppix things seem to work.

    It's an interrupt routing problem, which is a known issue with cardbus
    and DragonFly.

    You may be able to make it work by using polling on the network interface.
    Of the three drivers you mention, only the RL driver supports polling.
    This should also theoretically fix the interrupt livelock.

    Build your kernel and modules with DEVICE_POLLING and try to ifconfig
    up the RL interface with polling.

					Matthew Dillon 
					<dillon at xxxxxxxxxxxxx>

More information about the Kernel mailing list