Problems with -Preview and natd

Jon Hamilton hamilton at
Wed Aug 24 19:38:47 PDT 2005

I updated to -Preview this afternoon (about 4PM West Coast time) on one of my machines, and
have been suffering some heartburn since.  Upon reboot, I wound up in the debugger with
ip_output: no HDR which I traced to a bug (and patch) mentioned at .  I applied that patch,
but still no luck - now getting fatal trap 12's.  

Undaunted, I tried GENERIC and it worked fine.  So I figured I'd try to add some of the
non-GENERIC stuff and see what broke it.  I took GENERIC and added 
options   IPDIVERT
options   IPFIREWALL

at which point I start getting trap 12's.  I don't have much more information at hand,
but can reproduce the problem and transcribe a traceback if helpful.  Is this a known issue
with -Preview?  I'm upgrading from something around last December, if that's relevant.

Thanks for any help/suggestions/pointers.


   Jon Hamilton 
   hamilton at xxxxxxxxx

More information about the Kernel mailing list