uplcom(4) problem

Rahul Siddharthan rsidd at online.fr
Wed Oct 20 10:49:41 PDT 2004

Cedric Berger wrote:
>>    ucom0: Prolific Technology Inc. USB-Serial Controller, rev 1.10/3.00, addr
> 2
>Version 3 is the new PL2303X chip I think, slightly incompatible.
>I'm having the same problem on OpenBSD, A new batch of usb to serial
>converter we bought stopped working :(
>Apparently there is a patch floating for FreeBSD, I've not tested it:

Ah, definite progress, thanks.  I tried that patch, and the modem now
responds OK to the initialisation command (AT+CRM=1).  However, it
still times out on the dialling command (expecting CONNECT).

The linux 2.6.8 driver contains the same USB commands as this patch,
and a couple more; I tried inserting those too, and also changing the
CRTSCTS thing to 0x61 as in the linux driver, but no luck.  But then
I didn't even have luck trying to get linux 2.4 to work.  Perhaps
there are further weirdnesses with my device...


More information about the Kernel mailing list