ATA Patch #6

YONETANI Tomokazu qhwt+dfly at
Wed Nov 24 06:20:35 PST 2004

On Tue, Nov 23, 2004 at 01:41:13PM -0800, Matthew Dillon wrote:
> :Update: the lockup happens reading from an IDE drive with DMA enabled
> :(no mater what speed it is). Writing to an IDE drive doesn't seem
> :to have a problem. After I noticed this, I tried to reproduce the lockup
> :with dd command to perform a repeated short reads from the disk:
> :
> :# dd if=/dev/ad0s1f of=/dev/null
> :
> :There's a short period of time before the box becomes unresponsive,
> :during which pressing ctrl+T stops displaying the status(it eventually
> :locks up no matter whether I press ctrl+T or not). I managed to press
> :ctrl-alt-esc in the middle of(not sure if this is normal):
>     Hmm.  This is very intriguing.  Can you perhaps get a kernel dump
>     out of it?

I tried it but I couldn't. When I typed `panic' command in the DDB,
it just locked up after printing the following message:

ata0: resetting device ..

I thought resetting ATA mode has something to do with it, so I commented
out the first two lines in addump(), and this time I used the swap partition
from the second drive(I have two IDE disks on each channel on this box to
do a software striping), setting the ATA mode on that channel to PIO0. And
then when I typed `panic' command from DDB, it got stuck printing


on the screen. And as you know, I can't reproduce the lock-up when it's
operating in PIO mode... I'm going to tweak here and there to narrow down
the problem, and I'm going to try other DragonFly machines to make sure
that this is the only box that has the problem.

More information about the Kernel mailing list