New ISO available / ...

Garance A Drosihn drosih at
Sat May 1 16:27:50 PDT 2004

At 3:03 PM -0700 5/1/04, Matthew Dillon wrote:
:Is it true that I would need to
:      cd /dev
:      ./MAKEDEV ad0s2a
:before I could do anything with partitions in that second slice?
:I did that, and it seemed to do the trick, but the README didn't
:mention it.
    Hmm... Yes, I think I only create all the disk devices for the
    first slice by default.
    This is why I have the CD create MFS partitions for things
    like /dev, so you can easily create what you need :-)
Yes, that works nicely and was very helpful.  (although I still miss
how freebsd-5 "just creates" everything in /dev automatically. It
has been awhile since I've done a MAKEDEV by hand)
:all the /mnt partitions, and rebooted.  The boot-0 prompt (where you
:hit a function key to boot from some specific slice) would not let
:me select slice 2 (dragonfly) or slice 3 (an already-installed
    The boot loader should see the second slice... presuming that
    you installed bootblocks in it with disklabel.
It sees both the second and third slice, and recognizes them as
"FreeBSD", but it beeps whenever I try to hit the matching
function-key for either of those slices.
After futzing around with the initial install-ISO some more, I
found that my main problem with the my installation was due to
me putting 'ad0s1*' entries in fstab, instead of 'ad0s2*'...  So
I fixed that, and now I can start up my installation of dragonfly
in slice 2.
I still haven't figured out the problem with boot-0, but it is
worth noting that I tried reinstalling boot-0 from my FreeBSD 5.2.1
system, and it behaves the same way.  So, I think the problem is
specific to me or my disk, and not anything specific to dragonfly.
I tried redoing the 'disklabel -B ...' step, and then recreated the
disklabel with my correct partition info, but that did not help the
boot0-situation.  It also isn't clear to me why any of this would
have changed my previously-working slice 3, but that's okay.  I also
did a SUSE-linux install on this box (in slice-4), after the FreeBSD
install but before the Dragonfly install.  That installed GRUB (even
though I *thought* I asked it not to...) and that may have confused
everything related to booting.  I never got GRUB to boot FreeBSD
either, even though I followed instructions which claimed they would
work for FreeBSD.
So now I can boot either freebsd or dragonfly (after going through a
CD to get the initial boot-loader running), and that's fine for now.
I'll be rebuilding all of these installs soon, and I think I'll just
avoid the SUSE install this time.  I'll do *that* in Vmware where I
can isolate it, instead of on a real PC...
Garance Alistair Drosehn            =   gad at xxxxxxxxxxxxxxxxxxxx
Senior Systems Programmer           or  gad at xxxxxxxxxxx
Rensselaer Polytechnic Institute    or  drosih at xxxxxxx

More information about the Kernel mailing list