ACPI was the culprit

Dave Leimbach leimySPAM2k at
Wed Feb 18 11:37:54 PST 2004

David Rhodus <drhodus at xxxxxxxxxxx> writes:

Then it's a completely different issue causing the boot problem on DragonFly:

I tried all of the following and I still get hung up just after the detection
of my DVD-ROM.

hint.acpi.0.disabled=1 # disable ACPI (i386 only)
hw.ata.ata_dma=0       # disable IDE DMA
hw.ata.atapi_dma=0     # disable ATAPI/IDE DMA
hw.ata.wc=0            # disable IDE disk write cache
hw.eisa_slots=0        # disable probing for EISA devices

I built the GENERIC kernel and that doesn't boot.

I can't get FreeBSD 4.9 to run either but I did manage to get 5.2.1 RC2 
to boot in "Safe Mode" as well as the "disable ACPI" mode.

That's why I started looking down this path.


> Unless you have compiled your kernel with 'device acpica'
> you are not using ACPI under DragonFly.
> -DR
> Dave Leimbach wrote:
> >So for FreeBSD 5.2.1 at least ACPI was the reason I couldn't boot the
> > installer CD.  Choosing either a "Safe Mode" or "Disable ACPI" boot
> > worked.
> >
> > Is there a way to disable this at boot time in DragonFly as well by
> > interrupting the loader process?
> >
> >Dave
> >

More information about the Kernel mailing list