using pxeboot

Matthew Dillon dillon at
Mon Aug 16 22:41:34 PDT 2004

    The pxeboot we generate is entirely untested.  I don't know if 
    that has anything to do with your problem, though.

    What I recommend is that you first make sure your box's
    tftpd is working.  tftpd is usually started from inetd and inetd
    is not started by default.  If you cannot tftp a file from your
    tftp server then that has to be fixed before anything else.

    Next, I would just use a simple filename, e.g.:

    filename "pxeboot"

    And place both pxeboot and the kernel you wish to boot in your tftp

    I would leave the tftp directory at its default chroot, "/tftpboot",
    and copy the necessary files into that directory.

					Matthew Dillon 
					<dillon at xxxxxxxxxxxxx>

:Is boot/pxeboot from the installer disk ready
:to use?  in my dhcpd.conf I'm using
:filename "boot/pxeboot";
:while making the cdrom the tftpd root
:I've also tried
:filename "pxeboot";
:while making the cdrom/boot the tftpd root
:I even tried copying the cdrom to disk and
:adding a symlink "pxeroot -> ." in the top
:directory because pxeboot seems to look for
:that as its root.
:my logs show boot/pxeroot gets downloaded,
:I think it's running but gets stuck (can't
:load kernel) and it does not request files
:from the tftpd. :-\
:// George
:George Georgalis, Architect and administrator, Linux services. IXOYE
:  cell:646-331-2027  mailto:george at xxxxxxxxx
:Key fingerprint = 5415 2738 61CF 6AE1 E9A7  9EF0 0186 503B 9831 1631

More information about the Kernel mailing list