cvs commit: src/share/mk Makefile src/gnu/usr.bin/cc40 Makefile Makefile.langs Makefile.tgt src/gnu/usr.bin/cc40/c++ Makefile g++40.1 src/gnu/usr.bin/cc40/c++filt Makefile src/gnu/usr.bin/cc40/cc ...

walt wa1ter at
Fri Jun 10 06:46:58 PDT 2005

Simon 'corecode' Schubert wrote:
On 09.06.2005, at 20:16, walt wrote:

# if you like a gcc40 compiled gcc40, do those as well:
make cleandir
make cleandir
The first cleandir *removes* the obj directories, which is why I get
the warning below.  Seems like the second cleandir should be a make obj
Warning: Object directory not changed from original  

>> I went from there to
the gnu/lib steps you posted, but I got the same error for a missing
-lgcc -- using either gcc34 and gcc40.

same in this dir then, but it sets CCVER itself (see
env HOST_CCVER=gcc34 make depend
I still get the same error:
===> libstdc++
building shared library
rm -f
ln -fs
cc  -shared -Wl,-x  -o -Wl,-soname, 
`lorder bitmap_allocator.So pool_allocator.So mt_allocator.So codecvt.So 
complex_io.So ctype.So debug.So debug_list.So functexcept.So 
globals_locale.So globals_io.So ios.So ios_failure.So ios_init.So 
ios_locale.So limits.So list.So locale.So locale_init.So 
locale_facets.So localename.So stdexcept.So strstream-fixed.So tree.So 
allocator-inst.So concept-inst.So fstream-inst.So ext-inst.So io-inst.So 
istream-inst.So istream.So locale-inst.So locale-misc-inst.So 
misc-inst.So ostream-inst.So sstream-inst.So streambuf-inst.So 
streambuf.So string-inst.So valarray-inst.So wlocale-inst.So 
wstring-inst.So codecvt_members.So collate_members.So ctype_members.So 
messages_members.So monetary_members.So numeric_members.So 
time_members.So basic_file_stdio.So c_locale.So atomicity.So signbit.So 
signbitf.So stubs.So del_op.So del_opnt.So del_opv.So del_opvnt.So 
eh_alloc.So eh_aux_runtime.So eh_catch.So eh_exception.So eh_globals.So 
eh_personality.So eh_term_handler.So eh_terminate.So eh_throw.So 
eh_type.So eh_unex_handler.So guard.So new_handler.So new_op.So 
new_opnt.So new_opv.So new_opvnt.So pure.So tinfo.So tinfo2.So vec.So 
vterminate.So cp-demangle.So | tsort -q` -lm
/usr/libexec/binutils215/elf/ld: cannot find -lgcc

I don't see why lgcc is getting pulled in.  Any ideas?

More information about the Commits mailing list