[DragonFlyBSD - Bug #2917] da8: reading primary partition table: error accessing offset 000000000000 for 512

bugtracker-admin at leaf.dragonflybsd.org bugtracker-admin at leaf.dragonflybsd.org
Tue Sep 19 18:29:32 PDT 2017

Issue #2917 has been updated by liweitianux.

ollehar wrote:
> liweitianux wrote:
> > I think I found this bug is related to the "ehci" driver in DFly.  
> > 
> > I took some efforts to make DFly run on my X220.  Then I try to read the USB (2.0) stick from it, but it doesn't work with "ehci" driver loaded.
> How did you manage to boot dfly without the ehci driver? I'm facing this exact problem with my X220.

In fact, it took me quite some effort to install DFly on my X200 (also X220), then I managed to find that this issue is in the "ehci" driver from the installed DFly system (I can kldload and kldunload the "ehci" and "xhci" drivers and check the logging messages).

By reading the loader(8) man page, there is a description on how to disable the auto loading of "ehci" (USB2.0) driver: go to the loader prompt, and input:
lunset ehci_load
set hint.ehci.0.disabled=1

WARNING: This issue of course exists in the installed DFly system, thus you can only work with the slow "ohci" (USB1.1) driver on X200/X220.

NOTE: I tried install FreeBSD and OpenBSD on my X200 (X220 should be similar), and both of them works well (w.r.t. the USB2.0 driver).  However, DFly runs much faster compared to them, especially to OpenBSD.


Bug #2917: da8: reading primary partition table: error accessing offset 000000000000 for 512

* Author: liweitianux
* Status: New
* Priority: Normal
* Assignee: 
* Category: Driver
* Target version: 

Recently, I tried to install DragonFly BSD on my old ThinkPad X200 with both the 20160512-snapshot and 4.4.3-release USB image.  However, DragonFly failed to mount root from the USB device.

I enabled the verbose boot, and got the following error message:
(da8:umass-sim0:0:0:0): Request completed with CAM_REQ_CMP_ERR
(da8:umass-sim0:0:0:0): Retrying Command
(da8:umass-sim0:0:0:0): error 5
(da8:umass-sim0:0:0:0): Retries Exhausted
da8: reading primary partition table: error accessing offset 000000000000 for 512
Mounting root from ufs:da8s1a
no disk named 'da8s1a'
setrootbyname failed
ffs_mountroot: can't find rootvp
kthread 0xffffffe02050d700 syncer3 has exited
Root mount failed: 6

And there does not exist the 'da8s1a' device when listing:
mountroot> ?
Possibly valid devices for root FS:
 "vn0"  "vn1"  "vn2"  "vn3"  "md0"  "md0s0"  "sg8"  "sg0"  "da8"  "da0"  "da0s1"  "da0s2"  "da0s5"  "da0s6"  "da0s7"  "mapper/control"

I also tried to disable the "xhci" load, but the same issue remained.

On the other hand, I tried to install FreeBSD (11-current) on that laptop and succeeded.  And I can read the same USB device (with the DragonFly image dd'd into it) under FreeBSD (with the "geom_part_bsd64" module loaded).

I noticed there already existed a related bug report #2822 with this similar issue.  But I think this bug may not related with the USB3.0, but very likely due to the CAM, and that bug stalls for a long time.  Therefore I decide to open a new bug report.

It's my pleasure to provide any further information if necessary.

Best regards!

You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

More information about the Bugs mailing list