[DragonFlyBSD - Bug #2975] (Resolved) Strange corruption with graphics/darktable and OpenGL

bugtracker-admin at leaf.dragonflybsd.org bugtracker-admin at leaf.dragonflybsd.org
Tue Apr 4 00:34:54 PDT 2017

Issue #2975 has been updated by mneumann.

Status changed from New to Resolved

Fixed in https://gitweb.dragonflybsd.org/dragonfly.git/commit/16fb9086b36e7c7d81241bbd6502634e40346c7b

Bug #2975: Strange corruption with graphics/darktable and OpenGL

* Author: mneumann
* Status: Resolved
* Priority: Normal
* Assignee: 
* Category: 
* Target version: 
The first time I run "darktable", everything is fine. When I close it, and start it again, it fails with the following error:

    ld-elf.so.2: assert failed: /usr/src/libexec/rtld-elf/rtld.c:3045

    Signal 0

When I reinstall darktable (pkg remove darktable && pkg ins darktable), and then start it again, it works. But again, the second time, it fails with the same error.

This is my configuration:

    DragonFly babel.localnet 4.7-DEVELOPMENT DragonFly v4.7.0.1064.g9294ae-DEVELOPMENT #14: Wed Dec 28 14:45:50 CET 2016
        mneumann at babel.localnet:/usr/obj/usr/src/sys/X86_64_GENERIC  x86_64

I am using radeonkms. Is something corrupting my memory? Maybe OpenGL?

You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

More information about the Bugs mailing list