[DragonFlyBSD - Bug #2952] (Closed) vkernel crashes during boot

bugtracker-admin at leaf.dragonflybsd.org bugtracker-admin at leaf.dragonflybsd.org
Mon Oct 3 01:58:10 PDT 2016

Issue #2952 has been updated by zhtw.

Status changed from Feedback to Closed

I'm closing this ticket because the problem was solved for me. But I wander if it makes sense to back-port (basically cherrypick and submit as there are no conflicts) the two commits that solved the problem from master to DragonFly_RELEASE_4_6?

Bug #2952: vkernel crashes during boot

* Author: zhtw
* Status: Closed
* Priority: Normal
* Assignee: tuxillo
* Category: vkernel
* Target version: 
Can't start vkernel no my 4.6 machine:

a at kl:~$ uname -a
DragonFly kl.zta.lk 4.6-RELEASE DragonFly v4.6.0.10.g16fba-RELEASE #10: Wed Aug 17 14:26:31 CEST 2016     root at kl.zta.lk:/usr/obj/usr/src/sys/X86_64_GENERIC  x86_64
@kl:~$ sudo /var/vkernel/4.6/boot/kernel/kernel -m 2g -r /vhost/dev/root.img -I auto:bridge0 -d -p /var/run/vkernel.
Using memory file: /var/vkernel/memimg.000003
KVM mapped at 0x8000000000-0x10000000000
Copyright (c) 2003-2016 The DragonFly Project.
Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
DragonFly v4.6.0.20.ged336-RELEASE #16: Wed Sep 21 14:46:27 CEST 2016
    root at kl.zta.lk:/usr/obj/usr/src/sys/VKERNEL64
real memory = 2147483648 (2097152K bytes)
avail memory = 2027917312 (1980388K bytes)

Fatal trap 12: page fault while in kernel mode
cpuid = 0
fault virtual address   = 0x9
fault code              = supervisor read, page not present
instruction pointer     = 0x2b:0x6ef9b9
stack pointer           = 0x10:0x7fffffffe6f0
frame pointer           = 0x10:0x1
processor eflags        = interrupt enabled, resume, IOPL = 0
current process         = 0 ()
current thread          = pri 12
 <- SMP: XXX
kernel: type 12 trap, code=0

CPU0 stopping CPUs: 0x0000000000000000
Stopped at      0x6ef9b9:       movq    0x8(%rbp),%rdi

Interestingly, I was able to start the 4.4 vkernel some time ago, but I recently recompiled it and it started to crash the same way 4.6 does. I still have access to my working 4.4 vkernel, but don't know what to compare to see the difference.

You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

More information about the Bugs mailing list