[DragonFlyBSD - Bug #2686] kernel 3.8.1 freezes and panics at boot

bugtracker-admin at leaf.dragonflybsd.org bugtracker-admin at leaf.dragonflybsd.org
Sun Jun 28 19:25:33 PDT 2015

Issue #2686 has been updated by peeter.

File 0001-Program-PAT-indices-5-as-WP-from-default-WT-and-6-as.patch added


I've come back to this issue---and while I don't have a solution yet it seems you were on the right track Markus. It seems there are several issue involved. The patch you gave above is part of the solution. The discussion in the FreeBSD list



shows that many macbookpro models had an issue with PAT and changing from bits (4, 5) to bits (5, 6) resolved that. 

I improved Markus' patch a little (attached) bit since you also have to change the masks for the MSR register accordingly [1]. With this patch the system gets ACPI working in 


as confirmed in the FreeBSD list and macbookpro5,5 I can confirm myself. Since FreeBSD boots on other systems the patch does not affect systems that work either way.

Question: the original FreeBSD commit


also changes the pmap_cache_bits() routine; DragonFly pmap.c does not have this routine but it should be checked if there might be similar routines that need adjusting.

The next step: I suspect there is something off with the acpi--pci link since the error before crash is that _PRT is not found. I'll dig further. 


[1] pages 11-34 to 11-35, Vol. 3A in: http://www.intel.com/content/dam/www/public/us/en/documents/manuals/64-ia-32-architectures-software-developer-system-programming-manual-325384.pdf


Bug #2686: kernel 3.8.1 freezes and panics at boot

* Author: peeter
* Status: New
* Priority: Normal
* Assignee: profmakx
* Category: 
* Target version: 
DFly 3.6.x x86_64 boots and runs fine on my laptop
(macbookpro5,5), the 3.8.1 install iso freezes at boot. (acpi/ehci
disabled in both cases.) These are the last lines before freezing

--- ---
pci0: <processor> (vendor 0x10de, dev 0x0aa3) at device 3.5 irq 14
ohci0: <nVidia nForce MCP79 USB Controller> [tentative] mem
0xd3488000-0xd3488fff irq 11 at device 4.0 on pci0
ohci0: Reserved 0x1000 bytes for rid 0x10 type 3 at 0xd3488000

Since 3.6.x boots and runs fine (with acpi disabled) on this machine, 
I thought the freeze was related to the new usb. So upgraded
3.6.2 to 3.8.1 via git, did buildworld and buildkernel with WANT_OLDUSB=yes
in /etc/make.conf. The system now panics at boot, showing

fwohci0: <1394 Open Host Controller Interface> [tentative] mem
0xd3100000-0xd3100fff irq 7 at device 0.0 on pci4
fwohci0: latency timer 0 -> 32.
fwohci0: cache size 64 -> 64.
fwohci0: Reserved 0x1000 bytes for rid 0x10 type 3 at 0xd3100000

and then giving the db> prompt but because it freezes, or at least the
keyboard freezes, I can't call dumpsys. So unfortunately there's no
crash dump. I could then boot and run the system with the old 3.6.2

Further: since fwohci0 was the last line in the previous message, I 
recompiled the 3.8.1 kernel without firewire: 

# FireWire support
#device		firewire	# FireWire bus code
#device		sbp		# SCSI over FireWire (Requires scbus and da)
#device		fwe		# Ethernet over FireWire (non-standard!)

This causes kernel panic much later in the boot at umass and gives a db> prompt
that is functional but call dumpsys returns only 0 and there is no still no core dump. 

I also tried booting FreeBSD 10.0 to see how the (new) usb stack
fares. It boots fine. I attach the verbose dmesg for both FBSD 10 and
DFly 3.6.2 just in case.

I wonder if there's a way to get a debug or dumpsys for 3.8? Could
vkernel help or is it isolated from hardware?




DFly-3.6-verbose.dmesg (41.3 KB)
FBSD-10.0-verbose.dmesg (61.6 KB)
dfly-3.6-x86_64-macbookpro5,5-acpidump-b.tgz (10.4 KB)
0001-Program-PAT-indices-5-as-WP-from-default-WT-and-6-as.patch (1.4 KB)

You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

More information about the Bugs mailing list