[DragonFlyBSD - Bug #1718] (Feedback) IDE disk drive not detected by x86_64 2.6.1 Live CD

bugtracker-admin at leaf.dragonflybsd.org bugtracker-admin at leaf.dragonflybsd.org
Mon Jan 19 04:22:37 PST 2015

Issue #1718 has been updated by tuxillo.

Description updated
Category set to Kernel
Status changed from New to Feedback
Assignee deleted (0)
Target version set to 4.2.x


Is it possible that you try it again with latest master?

Antonio Huete

Bug #1718: IDE disk drive not detected by x86_64 2.6.1 Live CD

* Author: bcox
* Status: Feedback
* Priority: Normal
* Assignee: 
* Category: Kernel
* Target version: 4.2.x
I've been attempting to install DragonFly 2.6.1 (x86_64 version) onto an IDE
hard drive with no luck so far.  I have a Gigabyte EP45-DS3L motherboard with a
JMicron JMB368 IDE controller, a SATA DVD drive, a SATA2 WD Caviar disk drive
and an older WD Caviar IDE drive.  Both SATA drives are running in AHCI mode and
are detected by the kernel just fine.  (Unfortunately, I don't have enough
contiguous free space to install DragonFly with the HAMMER filesystem on the
SATA disk drive, hence the reason I tried to use the older spare IDE drive.)

FreeBSD 8.0 Live CD and Debian Linux 2.6.32 can see all three drives just fine,
but for some reason the IDE disk isn't getting attached by DragonFly.  I tried
turning off AHCI mode and running the SATA drives in legacy IDE mode, and
DragonFly finds the SATA drives (as IDE devices) just fine, but still no
attachment of the IDE disk.  My BIOS also has an option to run SATA drives in
"native IDE" mode, but that caused all sorts of problems involving
"TEST_UNIT_READY taskqueue timeout" and "xft: func = 0xffffffff8016b5d8 arg=0"
error messages and resulted in the kernel getting stuck in timeout loops.  I
should note that the JMicron controller itself is detected in all cases.

Matt Dillon helped me out on the IRC channel and suggested some things like
booting without ACPI, but nothing worked in the end.  He suspects that there's a
PCI resource issue involved.

Attached is the verbose dmesg output with AHCI mode enabled for the SATA drives. 
In it I found that device_probe_and_attach is returning error code 6 when
probing the JMicron controller (atapci0).

dfbsd.dmesg (58.3 KB)
dfbsd.pciconf (1.8 KB)

You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

More information about the Bugs mailing list