[DragonFlyBSD - Bug #2675] Ultimate N WiFi Link 5300 get iwn_intr: fatal firmware error on 5GHz

bugtracker-admin at leaf.dragonflybsd.org bugtracker-admin at leaf.dragonflybsd.org
Wed Nov 12 14:37:22 PST 2014

Issue #2675 has been updated by swildner.

Related to Bug #2733: iwn firmware error rendering xserver unusable added

Bug #2675: Ultimate N WiFi Link 5300 get iwn_intr: fatal firmware error on 5GHz

* Author: revuwa
* Status: New
* Priority: Low
* Assignee: 
* Category: Driver
* Target version: 3.8.0
I'm using a Lenovo Thinkad X200s with Intel Ultimate N WiFi Link 5300.

On Dragonfly BSD 3.6.2 it worked perfectly without any errors (and exactly the same configuration). Since 3.7.X and the actual testes 3.8.0RC my WiFi decive throws the following error on every try to load it (also over manual /etc/rc.d/netif restart):

### dmesg.boot (with rc_debug enabled) ###
iwn0: iwn_intr: fatal firmware error
firmware error log:
  error type      = "SYSASSERT" (0x00000005)
  program counter = 0x00003130
  source line     = 0x00000585
  error data      = 0x0000000100000000
  branch link     = 0x0000312A0000312A
  interrupt link  = 0x0000091600000000
  time            = 1270108785
driver status:
  tx ring  0: qid=0  cur=0   queued=0  
  tx ring  1: qid=1  cur=0   queued=0  
  tx ring  2: qid=2  cur=0   queued=0  
  tx ring  3: qid=3  cur=3   queued=0  
  tx ring  4: qid=4  cur=0   queued=0  
  tx ring  5: qid=5  cur=0   queued=0  
  tx ring  6: qid=6  cur=0   queued=0  
  tx ring  7: qid=7  cur=0   queued=0  
  tx ring  8: qid=8  cur=0   queued=0  
  tx ring  9: qid=9  cur=58  queued=0  
  tx ring 10: qid=10 cur=0   queued=0  
  tx ring 11: qid=11 cur=0   queued=0  
  tx ring 12: qid=12 cur=0   queued=0  
  tx ring 13: qid=13 cur=0   queued=0  
  tx ring 14: qid=14 cur=0   queued=0  
  tx ring 15: qid=15 cur=0   queued=0  
  tx ring 16: qid=16 cur=0   queued=0  
  tx ring 17: qid=17 cur=0   queued=0  
  tx ring 18: qid=18 cur=0   queued=0  
  tx ring 19: qid=19 cur=0   queued=0  
  rx ring: cur=11

I just load 'iwn5000fw_load="YES"' over loader.conf, because the other modules (if_iwn.ko, wlan_ccmp.ko, wlan_tkip.ko) are loaded by the generic kernel. This is what I've loaded, too:

### kldstat ###
Id Refs Address            Size     Name
 1   28 0xffffffff80200000 15a8710  kernel
 2    1 0xffffffff817a9000 13020    snd_hda.ko
 3    2 0xffffffff817bd000 31bf8    sound.ko
 4    3 0xffffffff817ef000 bf758    acpi.ko
 5    1 0xffffffff818af000 c7a0     ehci.ko
 6    2 0xffffffff818bc000 f4c0     dm.ko
 7    1 0xffffffff818cc000 1c4f8    dm_target_crypt.ko
 8    4 0xffffffff827e9000 58d0     libiconv.ko
 9    1 0xffffffff827ef000 20c8     libmchain.ko
10    1 0xffffffff827f2000 f98      msdos_iconv.ko
11    1 0xffffffff827f3000 f88      ntfs_iconv.ko
12    2 0xffffffff827f4000 10a38    ntfs.ko
13    1 0xffffffff82805000 fd0      cd9660_iconv.ko
14    1 0xffffffff82806000 5928     acpi_video.ko
15    1 0xffffffff8280c000 70c48    drm.ko
16    2 0xffffffff8287d000 2ec8     iicbus.ko
17    1 0xffffffff82880000 53fc8    iwn5000fw.ko
18    1 0xffffffff828d4000 1da8     coretemp.ko
19    1 0xffffffff828d6000 68d0     acpi_thinkpad.ko
20    1 0xffffffff828dd000 3dd0     est.ko
21    1 0xffffffff83042000 35000    pf.ko

### rc.conf (relevant entries) ###
ifconfig_wlan0="up DHCP WPA mode 11a"

### wpa_supplicant.conf ###
 ssid="my SSID name"
 psk="my secure passphrase"

### sysctl.conf (relevant entries) ###

In IRC at #dragonflybsd on EFNet @profmakx wrote: "I have iwn4965 and iwn6000, both work".

I've just tested (just for fun) to replace all that modules (if_iwn.ko, wlan_ccmp.ko, wlan_tkip.ko, iwn5000fw.ko) one by one and all together with the older one from v3.6.2. The result was exactly the same error.

I've found a FreeBSD issue with parallels:

Thanks in advance for any help!

You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

More information about the Bugs mailing list