[DragonFlyBSD - Bug #2686] kernel 3.8.1 freezes and panics at boot

bugtracker-admin at leaf.dragonflybsd.org bugtracker-admin at leaf.dragonflybsd.org
Wed Jun 25 05:42:34 PDT 2014

Issue #2686 has been updated by peeter.

Hi Markus

Thanks. The code is here:

--- sys/bus/u4b/controller/ohci.c ---

static usb_error_t
ohci_controller_init(ohci_softc_t *sc, int do_suspend)
    struct usb_page_search buf_res;
    uint32_t i;
    uint32_t ctl;
    uint32_t ival;
    uint32_t hcr;
    uint32_t fm;
    uint32_t per;
    uint32_t desca;

    /* Determine in what context we are running. */
    ctl = OREAD4(sc, OHCI_CONTROL);
    if (ctl & OHCI_IR) {
	/* SMM active, request change */
	DPRINTF("SMM active, request owner change\n");
	kprintf("0:");  //debug
	kprintf("1:");  //debug
	for (i = 0; (i < 100) && (ctl & OHCI_IR); i++) {
	    kprintf(".");  //debug
	    usb_pause_mtx(NULL, hz / 1000);
	    ctl = OREAD4(sc, OHCI_CONTROL);
	kprintf("2:");  //debug
	if (ctl & OHCI_IR) {
			  "SMM does not respond, resetting\n");
	    goto reset;
    } else {
	DPRINTF("cold started\n");
--- ---



Bug #2686: kernel 3.8.1 freezes and panics at boot

* Author: peeter
* Status: New
* Priority: Normal
* Assignee: profmakx
* Category: 
* Target version: 
DFly 3.6.x x86_64 boots and runs fine on my laptop
(macbookpro5,5), the 3.8.1 install iso freezes at boot. (acpi/ehci
disabled in both cases.) These are the last lines before freezing

--- ---
pci0: <processor> (vendor 0x10de, dev 0x0aa3) at device 3.5 irq 14
ohci0: <nVidia nForce MCP79 USB Controller> [tentative] mem
0xd3488000-0xd3488fff irq 11 at device 4.0 on pci0
ohci0: Reserved 0x1000 bytes for rid 0x10 type 3 at 0xd3488000

Since 3.6.x boots and runs fine (with acpi disabled) on this machine, 
I thought the freeze was related to the new usb. So upgraded
3.6.2 to 3.8.1 via git, did buildworld and buildkernel with WANT_OLDUSB=yes
in /etc/make.conf. The system now panics at boot, showing

fwohci0: <1394 Open Host Controller Interface> [tentative] mem
0xd3100000-0xd3100fff irq 7 at device 0.0 on pci4
fwohci0: latency timer 0 -> 32.
fwohci0: cache size 64 -> 64.
fwohci0: Reserved 0x1000 bytes for rid 0x10 type 3 at 0xd3100000

and then giving the db> prompt but because it freezes, or at least the
keyboard freezes, I can't call dumpsys. So unfortunately there's no
crash dump. I could then boot and run the system with the old 3.6.2

Further: since fwohci0 was the last line in the previous message, I 
recompiled the 3.8.1 kernel without firewire: 

# FireWire support
#device		firewire	# FireWire bus code
#device		sbp		# SCSI over FireWire (Requires scbus and da)
#device		fwe		# Ethernet over FireWire (non-standard!)

This causes kernel panic much later in the boot at umass and gives a db> prompt
that is functional but call dumpsys returns only 0 and there is no still no core dump. 

I also tried booting FreeBSD 10.0 to see how the (new) usb stack
fares. It boots fine. I attach the verbose dmesg for both FBSD 10 and
DFly 3.6.2 just in case.

I wonder if there's a way to get a debug or dumpsys for 3.8? Could
vkernel help or is it isolated from hardware?




DFly-3.6-verbose.dmesg (41.3 KB)
FBSD-10.0-verbose.dmesg (61.6 KB)

You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

More information about the Bugs mailing list