[DragonFlyBSD - Bug #2274] C12 problem on leaf.dragonflybsd.org

Alex Hornung via Redmine bugtracker-admin at leaf.dragonflybsd.org
Tue Feb 28 00:14:48 PST 2012

Issue #2274 has been updated by Alex Hornung.

Forgot to mention it in my last message:
using the TIOCSETA ioctl on a pty device (i.e. tcsetattr) causes a flush. This happens on most BSDs, and there is no guarantee that I'm aware of that it shouldn't happen. If you rely on it not happening, you are relying on undefined behaviour.

Bug #2274: C12 problem on leaf.dragonflybsd.org

Author: Robin Carey
Status: Rejected
Priority: Low
Target version: 

Dear DragonFlyBSD bugs,

I reported this problem just recently, and then mistakenly believed an O/S
upgrade on
leaf.dragonflybsd.org had solved the problem. Unfortunately, that was not
the case (I
had changed the code during testing/debugging and had forgot that I had
the code, which led to me believing the problem had been solved).

The problem is with C12 (C12G22r2) operation on leaf.dragonflybsd.org; the
code can be downloaded from:


The problem manifests as a termios(4)/Terminal problem, e.g.

Local echo is not switched off (there are probably other problems

Since C12G22r2 works fine on OpenBSD-4.7/i386 and
FreeBSD-9.0/i386, I conclude the problem is with


Robin Carey BSc

You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

More information about the Bugs mailing list