dsched_fq and occasional console freeze

elekktretterr at exemail.com.au elekktretterr at exemail.com.au
Sun Oct 17 15:36:45 PDT 2010

> Hi.
> When the current dsched policy is set to fq, the console (or ssh
> connection)
> occasionally freezes (becomes unresponsive, even to ctrl+T).  However,
> I can still switch between ttyvN terminals by pressing Alt+Fn keys,
> and drop to DDB (I remember reading a similar description in the past,
> but I couldn't find the message in my mailbox).
> Unfortunately, the kernel dumping locks up too in that case
> (no progress is printed on the screen), so no vmcore is available
> at the moment.  FWIW, dsched_fq is loaded as kernel module and the policy
> is set via /etc/rc.d/sysctl.
> This is on an Atom D510 with 4G bytes of RAM and running a very recent
> -DEVELOPMENT x86_64 kernel; I haven't tried it on a PC running 32-bit
> version yet.

I wonder if this:

is related, I did enable DSCHED_FQ via sysctl just before I ran "hammer
cleanup" I remember now, and the symptoms are same - freeze but can switch
between terminals, but can't actually execute any command because they are
all "hanging", for about 5 minutes and eventually freeze completely but
without a kernel dump.


More information about the Bugs mailing list