Problems with a SATA DVD burner

Vincent Stemen vince.dragonfly at
Sat Nov 15 13:43:57 PST 2008

On Sat, Nov 01, 2008 at 09:43:05PM +0000, Steve O'Hara-Smith wrote:
> 	Hi,
> 	My trusty (well not so trusty) DVD burner started acting up
> (intermittently refusing to eject or load) so I had to pick up a
> replacement, the only one available locally at a sane price was a SATA unit
> so with a promise that I could return it I bought it and put it in my
> workstation box and booted DragonFly.
> 	As soon as the atapicam driver got to it an interrupt storm started
> and the livelock went on, and off and on and off and ... well you get the
> idea - 80% CPU utilisation in interrupt. A little research suggested DMA
> problems as a possible cause - setting hw.ata.atapi_dma=0 in loader.conf
> didn't help.
> 	More research suggested a problem with having both atapicd and
> atapicam loaded, so I built a kernel without atapicd. That got rid of the
> livelock and the burner worked. Then I remembered that DMA was off so I
> reenabled that and rebooted, the livelock promptly came back.
> 	I haven't tried atapicd with DMA, but as far as I know there's no
> software that will write a DVD through atapicd so that's not really an
> option.
> 	Relevant bits of verbose boot dmesg are very odd as they seem to
> show that two devices are on ata4 one of them a UDMA133 hard disc, the
> other the SATA DVD burner.
> 	For now it's usable but not ideal, does anyone have any suggestions
> as to how I might go about getting DMA working for this drive ?

I was a bit surprised that I saw no replies to this.  Here is my 2 cents

After having just bought a new SATA DVD burner and SATA card I ran in
this same problem and posted about it back on Jul 13, 2008 just before
the 2.0 release.  I finally ended up buying another new non-SATA burner
in order to be able use the machine.  Matt said he was pretty sure this
is an issue with the NATA driver.  Hasso Tepper said he has seen that
many times and thinks it is a bug in the hardware.  I don't think it is
since we have encountered it with various different hardware.  

Also, we tested with the freebsd-7.0 live file system CD on one of our
machines and it worked fine.  No livelock or other error messages.

To repeat some of my earlier posting on the subject, we have tested on
two different Intel machines, and an AMD64 machine, with an add on PCI
SiI 3512 SATA150 controller card.  We also tested with the on board VIA
6420 SATA150 controller on the AMD64 machine.  The problem exists in all
cases.  We have also tested with 3 different SATA CD drives.

In addition, we had the same problem with a friends laptop (I don't
remember the type) which had an SATA DVD, causing us to not be able to
run DFBSD on his laptop.

We have found no cases where SATA optical drives have been able to run
on Dragonfly with hardware available to us.  

With SATA drives becoming dominant this is becoming a serious show
stopper bug.  It is concerning that it is lingering for so long.  I hope
this becomes a priority.

More information about the Bugs mailing list