panic when umounting a msdosfs mount: "VOP_STDCLOSE: BAD WRITECOUNT 0xf2629e68 0"

Rumko rumcic at
Tue May 20 16:25:11 PDT 2008

Rumko wrote:

> Matthew Dillon wrote:
>> :If I remember correctly, I did mount it readonly, then did a umount -u,
>> :copied a file, ran sync (I'm not sure, but could've been more than one
>> :time) and tried umount-ing it.
>> :
>> :As for being reproducable ... I can try it again, if the need to reproduce
>> :it arises.
>> :--
>> :Regards,
>> :Rumko
>>     Being able to reproduce it allows you to test to see if my patch fixes
>>     the problem!
>>     However, in this case you don't need to worry about it.  I can reproduce
>>     the bug from the information you have given me and I will commit a fix
>>     to HEAD very soon.
>> -Matt
>> Matthew Dillon
>> <dillon at>
> Well, my plan was to reserve a couple of hours after you'd send a patch and
> first update to -HEAD again and try to reproduce it and apply the patch and
> try again ...

Well after that commit to HEAD, I can't reproduce the panic anymore (did play
quite a lot with that mount, but it worked without problems).

More information about the Bugs mailing list