partition oddity

Matthew Dillon dillon at
Sun May 18 09:16:00 PDT 2008

:>     on /dev/ad8s2d ?   If you do a fresh boot (i.e. never having tried to
:>     mount anything using that device), and then issue the dd, does it
:>     work differently?
:>     Does disklabel recognize the disk?
:>     Also try regenerating the /dev entry for ad8s2.
:>     cd /dev
:>     ./MAKEDEV ad8
:>     ./MAKEDEV ad8s2
:>     ./MAKEDEV ad8s2a
:I tried most of this, all negative.
:However, I _do_ have some partitions of the ad8s1 slice mounted (/, 
:/usr, etc.). Could it be because of this? I would think this shouldn't 
:affect partitions on ad8's other slices, right?
:I'll try later from a LiveCD.

    Is this on 1.12 or HEAD ?  I do recall a bug in the partition-open
    bitmap in the disk layer that I'm pretty sure I fixed in HEAD, but
    may not have fixed in 1.12.  It is possible there is an issue there,
    it is worth checking out.

					Matthew Dillon 
					<dillon at>

More information about the Bugs mailing list