kernel panic under install CD boot (cd9660-related)

Jan Martin Mathiassen dfbsd at
Sat Aug 23 15:18:30 PDT 2008

Just did a bit more testing.

Windows XP: works fine.
Debian 3.0: hangs during bootup of install cd
Debian 4.0r4: works fine.
FBSD7.0: complains with the following:
acd0: TIMEOUT - READ_BIG retrying (1 retry left)
acd0: TIMEOUT - READ_BIG retrying (0 retries left)
acd0: FAILURE - READ_BIG timed out
GEOM_LABEL: Label for provider acd0t01 is iso9660/FreeBSD_Install.
before apparently switching to a compatible mode of reading which works.
DFBSD1.1, 2.0, 2.1-DEVEL/DAILY (downloaded 2008.08.22): pops into
mountroot when it tries to mount the ide dvd drive. Tried with 2
different (and new) IDE cables as well, and also tried in a quadcore 
asus p5q with the exact same result. An old dual P3 box which I use as a 
firewall booted up just fine.

And just now I even tried to install it on the firewall (which doesn't 
die on itself during bootup of the install cd). That went fine, I tested 
that it supported a reboot, but when I moved the harddisk over to the 
asus p5n box in question, it dies during bootup. The last thing I see 
here is in the attached file "mountroot.txt".

So basically, something on the Asus p5n and p5q motherboards are too new 
to be supported, or there's a bug in the NATA module after it was ported 
from fbsd, because fbsd 7.0 works just fine.
pci0: <unknown card> (vendor=0x8086, dev=0x283e) at 31.3 irq 10
atapci3: <Intel ICH SATA300 controller> port 0xc800-0xc80f,0xc880-oxc88f,oxcc00-0xcc03,0xd000-0xd007,0xd080-0xd083,0xd400-0xd407 irq 10 at device 31.5 on pci0
ata7: <ATA channel 0> on atapci3
ata8: <ATA channel 1> on atapci3
pmtimer0 on isa0
fdc1: cannot reserve I/O port range
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio2: can't drain, serial port might not exist, disabling
ppc1: cannot reserve I/O port range
Mounting root from ufs:/dev/ad0s1a
no disk named ad0s1a
setrootbyname failed
ffs_mountroot: can't find rootvp
Root mount failed: 6

Manual root filesystem specification:
  <fstype>:<device>  Specify root (e.g. ufs:da0s1a)
  ?                  List valid disk boot devices
  panic              Just panic
  abort              Abort manual input


More information about the Bugs mailing list