[issue784] SATA no-go on ATI SB600 (K9AGM-FID)

Joe "Floid" Kanowitz sinknull at crater.dragonflybsd.org
Wed Sep 5 01:44:58 PDT 2007

Joe "Floid" Kanowitz <jkanowitz at snet.net> added the comment:

Uploading "happy_freesbie.dmesg" to issue 784 in the bugtracker, showing FreeBSD
6.2/FreeSBIE 2.0.1's ATA (NATA, I assume?) code picking up the SATA DVD device
with the "Native IDE" option enabled in the BIOS.

FreeBSD wasn't happy with the "AHCI" option either; I've been too distracted to
find out where FreeBSD is re: AHCI support in general.

I'll toss up a DragonFly dmesg with the "Native IDE" option on as well.

This experiment turned up an unrelated glitch in DragonFly where mounting the
(FAT-formatted) USB stick worked, ls worked, but copying off it has hung (the
device and shell, not the system) with:
[diagnostic] cache lock: blocked on 0xded18468 "happy_freesbie.dmesg"

Whatever's behind that might be fixed already.

It also turns up FreeBSD 6.2 misdetecting the UDMA100 HD (on the PATA
controller) as UDMA33.

-Joe "Floid" Kanowitz

DragonFly issue tracker <bugs at lists.dragonflybsd.org>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: bin00000.bin
Type: application/octet-stream
Size: 18589 bytes
Desc: "Description: Binary data"
URL: <http://lists.dragonflybsd.org/pipermail/bugs/attachments/20070905/0ced485f/attachment-0021.bin>

More information about the Bugs mailing list