[issue557] 1.9.0-DEVELOPMENT hangs with ACPI enabled

YONETANI Tomokazu qhwt+dfly at les.ath.cx
Sun Mar 4 09:33:54 PST 2007

On Wed, Feb 28, 2007 at 12:59:34PM -0300, Mariano Aliaga wrote:
> and started taking pictures to get a better shot. After watching them,
> I saw that "acpi_pcpu_get_id() failed" appears only 3 times
> (http://www.e-nix.com.ar/~maliaga/00003.jpg and
> (http://www.e-nix.com.ar/~maliaga/00004.jpg). So sorry, I thought they
> were 4 :-(

That's OK, debugging without a working keyboard is hard anyway :)

> >If it does, please try yet another patch attached to this message(after
> >reverting the last patches).  Also please make sure that the files in
> >/sys/dev/acpica5 or /sys/platform/pc32/acpica5 are up to date before
> >rebuilding the acpi driver.  This time you are going to try 6 to 11 for
> >debug.acpi.cpu.knob and see when it locks up.  If I'm not mistaken,
> >it should lock up before reaching to 11.
> For this I cvsupped last changes, applied your patch, and tried from
> knob 6 to 11. Unfortunately, it didn't lock on any of the tests, and
> the messages where the same than previous tests with knob 0 to 5.

Hmm... have you tried without setting debug.acpi.cpu.knob?  If I remember
correctly, the function trace for ACPI_PROCESSOR didn't show a line for
acpi_cpu_attach(), so I believed that it locked up before reaching to
attachment routine.  But if you forced to return at the entrance of
attachment routine(with knob 11) and it doesn't lock up.  That confuses me.
Anyway, I wrote another patch to narrow down the location.  Please undo
any changes to files under /sys/dev/acpica5, apply the patch attached
to this message, and reinstall the driver.  Now you have knobs 1 to 5.
This time, please add the following two lines in /boot/loader.conf:

and let me know lines in dmesg output beginning with "acpi_cpu"
if knob=4 didn't lock up your computer.


More information about the Bugs mailing list