ccd on NATA problem - ata0: FAILURE - oversized DMA transfer attempt 73728 > 65536

Matthew Dillon dillon at
Tue Jul 17 23:45:49 PDT 2007

:On Tue, Jul 17, 2007 at 10:52:05PM -0700, Matthew Dillon wrote:
:> :On Tue, Jul 10, 2007 at 12:58:16PM +0900, YONETANI Tomokazu wrote:
:> :> It worked fine as I tested lightly(-j2 buildworld).  I'll try to test later
:> :> with different max iosize of component devices.
:> :
:> :Hi, I tried to reduce the default max_iosize in ata_dmainit()
:> :to 64 * DEV_BSIZE(=32768), expecting that it reduces si_iosize_max
:> :as it's assigned ch->dma->max_iosize in ata_attach(), but now NATA
:> :fails setting up DMA.  Is there any other way to achive the reduced
:> :iosize?
:> :
:> :Cheers.
:>     Are you running the patch for CCD?  Which I did commit.
:Yes, I saw that it was committed.  I have the latest source,
:and in this case CCD is irrelavant (because it happens on non-ccd
:system, too).  The system using CCD is working just fine as my
:build machine.

    Can you get a ddb backtrace?

					Matthew Dillon 
					<dillon at>

More information about the Bugs mailing list