ac97 sound device not detected (alc655 codec)

walt wa1ter at
Thu Jan 4 12:02:26 PST 2007

Vincent Stemen wrote:
> ...
> I had to directly load the snd_via8233.ko module.  It turns out that
> snd.ko was apparently loading all the sound modules except for two.
> snd_via8233.ko and snd_uaudio.ko....

> So the question is, why did snd.ko not load two of the modules?  It is
> just my luck that it happens to be the one for our sound device.  Is
> that a bug or a feature?...

Very interesting.  You just solved a puzzle for me.  I tried compiling
the 'pcm' device into my custom kernel -- which never worked!  I always
had to load the via8233 module manually at boot, and now I know why.
(My SWAG would be that this is more buggish than featurish.)

Just as a minor aside, loading the via module will automatically pull in
the snd_pcm module, so you needn't load it explicitly.  As a more major
aside, I do not load the snd module at all, and yet my sound works fine.

Can you try loading only the snd_via8233.ko from loader.conf and see if
you get satisfactory sound?  What other modules get loaded when you try


More information about the Bugs mailing list